home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / net-misc / iputils-021109-r3 / iputils-021109-r3.ebuild < prev    next >
Text File  |  2005-10-13  |  2KB  |  86 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/iputils-021109-r3.ebuild,v 1.23 2005/05/30 02:35:15 solar Exp $
  4.  
  5. inherit flag-o-matic eutils toolchain-funcs
  6.  
  7. DESCRIPTION="Network monitoring tools including ping and ping6"
  8. HOMEPAGE="ftp://ftp.inr.ac.ru/ip-routing"
  9. SRC_URI="ftp://ftp.inr.ac.ru/ip-routing/${PN}-ss${PV}-try.tar.bz2
  10.     http://ftp.iasi.roedu.net/mirrors/ftp.inr.ac.ru/ip-routing/${PN}-ss${PV}-try.tar.bz2"
  11.  
  12. LICENSE="BSD"
  13. SLOT="0"
  14. KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
  15. IUSE="static ipv6 doc"
  16.  
  17. DEPEND="virtual/os-headers
  18.     doc? (
  19.         app-text/openjade
  20.         dev-perl/SGMLSpm
  21.         app-text/docbook-sgml-dtd
  22.         app-text/docbook-sgml-utils
  23.     )"
  24. RDEPEND=""
  25.  
  26. S=${WORKDIR}/${PN}
  27.  
  28. src_unpack() {
  29.     unpack ${A}
  30.     cd "${S}"
  31.     epatch "${FILESDIR}"/${P}-gcc34.patch
  32.     epatch "${FILESDIR}"/${PV}-no-pfkey-search.patch
  33.     epatch "${FILESDIR}"/${PV}-ipg-linux-2.6.patch #71756
  34.     epatch "${FILESDIR}"/${PV}-syserror.patch
  35.     epatch "${FILESDIR}"/${PV}-uclibc-no-ether_ntohost.patch
  36.     epatch "${FILESDIR}"/${P}-bindnow.patch #77526
  37.     # make iputils work with newer glibc snapshots
  38.     epatch "${FILESDIR}"/${P}-linux-udp-header.patch
  39.  
  40.     use static && append-ldflags -static
  41.     sed -i \
  42.         -e "/^CCOPT=/s:-O2:${CFLAGS}:" \
  43.         -e "/^CC=/s:.*::" \
  44.         -e '/^all:/s:check-kernel::' \
  45.         -e 's:-I$(KERNEL_INCLUDE)::' \
  46.         -e 's:-I/usr/src/linux/include::' \
  47.         Makefile \
  48.         || die "sed Makefile failed"
  49.     use ipv6 || sed -i -e 's:IPV6_TARGETS=:#IPV6_TARGETS=:' Makefile
  50. }
  51.  
  52. src_compile() {
  53.     tc-export CC AR
  54.     emake || die "make main failed"
  55.  
  56.     # We include the extra check for docbook2html 
  57.     # because when we emerge from a stage1/stage2, 
  58.     # it may not exist #23156
  59.     if use doc && type -p docbook2html ; then
  60.         emake -j1 html || die
  61.     fi
  62.     emake -j1 man || die "make man failed"
  63. }
  64.  
  65. src_install() {
  66.     into /
  67.     dobin ping || die "ping"
  68.     use ipv6 && dobin ping6
  69.     dosbin arping || die "arping"
  70.     into /usr
  71.     dosbin tracepath || die "tracepath"
  72.     use ipv6 && dosbin trace{path,route}6
  73.     dosbin clockdiff rarpd rdisc ipg tftpd || die "misc sbin"
  74.  
  75.     fperms 4711 /bin/ping
  76.     use ipv6 && fperms 4711 /bin/ping6 /usr/sbin/traceroute6
  77.  
  78.     dodoc INSTALL RELNOTES
  79.  
  80.     rm -f doc/setkey.8
  81.     use ipv6 || rm -f doc/*6.8
  82.     doman doc/*.8
  83.  
  84.     use doc && dohtml doc/*.html
  85. }
  86.